QuickBooks Online Payroll - Planned System Mainentance
Scheduled
in progress (4 days 58 minutes)
November 17, 1:00am
QuickBooks Online Payroll - Planned System Mainentance
Status: in progress
Start:
November 17, 1:00am
Estimated Duration: 120 minutes
Affected Components:
External Marketplace Services
QuickBooks Online
Canada
Update
November 17, 1:00am
November 17, 1:00am
QuickBooks Online Payroll planned system mainentance. We apologize for the inconvenience that this may cause and hope to quickly complete the maintenance to minimize any disruption of service during this time!