Potential issue detected on our services

Incident
March 31, 11:55am

Potential issue detected on our services

Status: closed
Start: March 07, 3:29pm
End: March 31, 11:55am
Duration: 23 days 19 hours 26 minutes
Affected Components:
Sherweb Hosted Services Cumulus Portal API Billing API
Update

March 07, 3:29pm

March 07, 3:29pm

We are currently experiencing an issue with the public API GetReceivableCharges, which is not returning certain data for some invoices issued since February 2025. Our technical teams are actively working to resolve this issue as soon as possible.

Please check back with this status page for developments regarding this issue.
Thank you for your patience. Our apologies for any inconvenience caused.

Best regards,
The Sherweb Technical Support Team

Update

March 25, 10:48am

March 25, 10:48am

We are still experiencing an issue with the public API GetReceivableCharges, which is not returning certain data for some invoices issued since February 2025. Our technical teams are actively working to resolve this issue as soon as possible.

Please check back with this status page for developments regarding this issue.Thank you for your patience. Our apologies for any inconvenience caused.

Best regards,
The Sherweb Technical Support Team

Resolved

March 31, 11:55am

March 31, 11:55am

Billing API services are now working normally again. All issues have been resolved. Thank you.