Issue detected on M365 Canada Self Service Restore Portal

Incident
June 04, 11:36am

Issue detected on M365 Canada Self Service Restore Portal

Status: in progress
Start: June 04, 11:36am
Affected Components:
Sherweb Hosted Services M365 backup powered by Veeam Canada East 1 Self-Service Portal
Update

June 04, 11:36am

June 04, 11:36am

We are currently investigating an issue impacting M365 Canada Self Service Restore Portal .

Impact Level: Identified. 

Observed Behavior:
 While using the self service restore portal, customers may face an intermittent issue where the page content is not properly loaded. Normally a retry will successfully load the content.

Current Progress: Our engineering team has identified the root cause and mitigaton measures will be applied on June 8th.