Issue detected on Cumulus

Incident
July 22, 3:57pm

Issue detected on Cumulus

Status: in progress
Start: July 20, 4:28pm
Affected Components:
Sherweb Hosted Services Cumulus Portal General API MFA: SMS MFA: Email Shopping Cart Billing API Shopping API
Update

July 20, 4:28pm

July 20, 4:28pm

We are currently investigating an issue impacting provisioning in Cumulus

Impact Level: Investigating

You may currently be experiencing issues when trying to reduce or revert Microsoft 365 subscription quantities, even in the 7-day cancellation window.

Current Progress: Our team is still investigating and working on identifying the cause of the issue.

Next Update: We will provide our next update by 4 PM EST, July 21st, 2026

Update

July 21, 3:40pm

July 21, 3:40pm

We are currently investigating an issue impacting provisioning in Cumulus

Impact Level: Investigating

You may currently be experiencing issues when trying to reduce or revert Microsoft 365 subscription quantities, even in the 7-day cancellation window.

Current Progress: Our team has opened a ticket with Microsoft, and we are actively working with them to resolve the issue.

Next Update: We will provide our next update by 4 PM EST, July 22nd, 2026

Update

July 22, 3:57pm

July 22, 3:57pm

We are currently investigating an issue impacting provisioning in Cumulus

Impact Level: Investigating

You may currently be experiencing issues when trying to reduce or revert Microsoft 365 subscription quantities, even in the 7-day cancellation window.

Current Progress: Our team has opened a ticket with Microsoft, and we are actively working with them to resolve the issue.

Next Update: We will provide our next update by 4 PM EST, July 24th, 2026