Issue detected on M365 Backup Powered by Veeam - USA & Canada

Incident
July 27, 4:35pm

Issue detected on M365 Backup Powered by Veeam - USA & Canada

Status: closed
Start: July 24, 4:34pm
End: July 27, 4:35pm
Duration: 3 days 1 minute
Affected Components:
Sherweb Hosted Services M365 backup powered by Veeam Canada East 1 United States East 1 General General Self-Service Portal Self-Service Portal Veeam Cloud Connect Veeam Cloud Connect
Update

July 24, 4:34pm

July 24, 4:34pm

We are currently investigating an issue impacting M365 Backup Powered by Veeam - USA & Canada .

Impact Level: Investigating

Obsereved Behavior :  Sharepoint and Onedrive backup jobs may fail to backup some of the objects with the following message : 

Cannot complete this action. Please try again. Total count of failed items: N


Current Progress: 
The issue is under investigation and we have engaged service provider. Additional information can be found in the following KB article : https://www.veeam.com/kb4793


Resolved

July 27, 4:35pm

July 27, 4:35pm

The issue affecting M365 Backup Powered by Veeam - USA & Canada has been resolved, and all services are now operating normally.

Impact Level: Resolved

If you are still experiencing service-related issues, please contact our support team for further assistance.