Update: Performance degraded - PSA billing integration

Incident
August 05, 3:50pm

Update: Performance degraded - PSA billing integration

Status: in progress
Start: July 31, 2:55pm
Affected Components:
Billing Integrations QuickBooks Online QuickBooks Desktop ConnectWise
Update

July 31, 2:55pm

July 31, 2:55pm

We are currently investigating an issue impacting our PSA billing Integration.

Impact Level: Investigating

Current Progress: Our engineering team has been mobilized and is actively investigating the problem to determine the root cause and restore service.

Next update: We will provide an update within 60 minutes.

Update

July 31, 3:46pm

July 31, 3:46pm

This is an update regarding the ongoing disruption to our PSA billing integration

Impact Level: Performance Degraded
You may currently be experiencing discrepancies have been identified in the data sent to PSA billing integrations. In certain cases, this may result in unexpected additional additions or contracts being created within connected PSA systems. Partners reviewing and sending monthly invoices may be impacted by inaccurate billing records and should perform additional validation before invoicing customers.

Current Progress:  Our team is still investigating and working on identifying the cause of the issue.


Next Update:  We will continue to monitor the status of service incident and will provide our next update by 12:00 EDT on Aug 3rd.

Update

August 03, 12:47pm

August 03, 12:47pm

This is an update regarding the ongoing disruption to our PSA billing integration

Impact Level: Performance Degraded
You may currently be experiencing discrepancies have been identified in the data sent to PSA billing integrations. In certain cases, this may result in unexpected additional additions or contracts being created within connected PSA systems. Partners reviewing and sending monthly invoices may be impacted by inaccurate billing records and should perform additional validation before invoicing customers.

Current Progress:  Our team is still investigating and working on identifying the cause of the issue.


Next Update:  We will continue to monitor the status of service incident and will provide our next update by 12:00 EDT on Aug 4th.

Update

August 04, 1:21pm

August 04, 1:21pm

This is an update regarding the ongoing disruption to our PSA billing integration

Impact Level: Performance Degraded
You may currently be experiencing discrepancies in the data sent to the PSA billing integrations. In certain cases, this may result in unexpected additional additions or contracts being created within connected PSA systems. Partners reviewing and sending monthly invoices may be impacted by inaccurate billing records and should perform additional validation before invoicing customers.

Current Progress:
Our team has identified the potential cause as it is the result of a combination change related to the recent Microsoft price update and specific PSA configurations. Our team is currently preparing a rollout that will automatically remove any duplicate entries created in affected PSAs that would negatively impact the invoice.

Next Update:
We will continue to monitor the implementation and will provide our next update by 14:30 EDT on Aug 4th.

Update

August 04, 2:40pm

August 04, 2:40pm

This is an update regarding the ongoing disruption to our PSA billing integration.

Impact Level: Performance Degraded
You may currently be experiencing discrepancies in the data sent to the PSA billing integrations. In certain cases, this may result in unexpected additional additions or contracts being created within connected PSA systems. Partners reviewing and sending monthly invoices may be impacted by inaccurate billing records and should perform additional validation before invoicing customers.

Current Progress: Our team is actively implementing a fix to address the issue and restore full service. We are closely monitoring the changes as they are applied.


Next Update: We will continue to monitor the fix implemented and will provide our next update by 16:00 EDT on Aug 4th

Update

August 04, 4:36pm

August 04, 4:36pm

This is an update regarding the ongoing disruption to our PSA billing integration.

Impact Level: Performance Degraded
You may currently be experiencing discrepancies in the data sent to the PSA billing integrations. In certain cases, this may result in unexpected additional additions or contracts being created within connected PSA systems. Partners reviewing and sending monthly invoices may be impacted by inaccurate billing records and should perform additional validation before invoicing customers.

Current Progress: Our team is actively implementing a fix to address the issue and restore full service. We are closely monitoring the changes as they are applied.

A notification will be sent to impacted partner with additional information once the fix will be applied 


Next Update: We will continue to monitor the fix implemented and will provide our next update by 9:00 EDT on Aug 5th

Update

August 05, 8:33am

August 05, 8:33am

This is an update regarding the ongoing disruption to o ur PSA billing integration.

Impact Level: Performance Degraded
You may currently be experiencing discrepancies in the data sent to the PSA billing integrations. In certain cases, this may result in unexpected additional additions or contracts being created within connected PSA systems. Partners reviewing and sending monthly invoices may be impacted by inaccurate billing records and should perform additional validation before invoicing customers.

Current Progress: Our team has completed the backend fix and is currently testing the solution. We actively monitoring the solution deployment to address the issue and restore full service.

A notification will be sent to impacted partner with additional information once the fix will be applied 


Next Update: We will continue to monitor the fix implemented and will provide our next update by 12 :00 EDT on Aug 5th

Update

August 05, 12:25pm

August 05, 12:25pm

This is an update regarding the ongoing disruption to our PSA billing integration.

Impact Level: Performance Degraded
You may currently be experiencing discrepancies in the data sent to the PSA billing integrations. In certain cases, this may result in unexpected additional additions or contracts being created within connected PSA systems. Partners reviewing and sending monthly invoices may be impacted by inaccurate billing records and should perform additional validation before invoicing customers.

Current Progress: Our team has successfully validated the backend solution and is currently deploying it in our production environment. We actively monitoring the deployment to address the issue and restore full service.

A notification will be sent to impacted partner with additional information once the fix will be applied 


Next Update: We will continue to monitor the fix implemented and will provide our next update by 15 :00 EDT on Aug 5th

Update

August 05, 3:50pm

August 05, 3:50pm

This is an update regarding the ongoing disruption to our PSA billing integration.

Impact Level: Performance Degraded
You may currently be experiencing discrepancies in the data sent to the PSA billing integrations. In certain cases, this may result in unexpected additional additions or contracts being created within connected PSA systems. Partners reviewing and sending monthly invoices may be impacted by inaccurate billing records and should perform additional validation before invoicing customers.

Current Progress: Our team has successfully validated the backend solution and is currently deploying it in our production environment. 

The deployment of the solution is ongoing and we are actively monitoring the deployment to address the issue and restore full service.

A notification will be sent to impacted partner with additional information once the fix will be applied 


Next Update: We will continue to monitor the fix implemented and will provide our next update by 20 :00 EDT on Aug 5th